Plugin & Theme Settings Guide

Logic Hop is designed to be compatible with third-party WordPress Plugins and Themes. However, some Plugins and Themes require special settings to work properly. Setting and configuration notes are regularly updated on this page.

If you are experiencing compatibility issues with a third-party Plugin or Theme, click here to contact us. Be sure to include the Plugin or Theme name, version and details about the issue.

WordPress Multisite Networks

A multisite network is a collection of sites that all share the same WordPress installation. They can also share plugins and themes. Multisite networks can be based on sub-domains or sub-directories.

Logic Hop is fully compatible with multisite networks using sub-domains and top-level domains via the Domain Mapping plugin. Logic Hop can be installed and activated as a Network Plugin or installed individually for each site. Each site will need its own Logic Hop account.

While Logic Hop will work with sub-directory multisite networks, it not recommended due to nature of the WordPress sub-directory structure. Each sub-directory site shares the same domain name and can have identical post IDs. This will cause post ID collisions and produce unreliable results.

Plugins

Cache Plugins

Cache Plugins help speed up WordPress by caching pages. Put simply, this means pages are dynamically generated once. Subsequent page views bypass the WordPress Engine and visitors are served the static cached pages.

While caching is great for speed and performance, it bypasses Pre-page Level and Page Level processing and the default Logic Hop functionality. For cache Plugin compatibility, Logic Hop has a Javascript Tracking feature which allows the use of any cache Plugin while keeping the benefit of the page view tracking, Goal tracking and page redirects.

Click here to learn how to use cache Plugins with Logic Hop.

qTranslate X

By default, the qTranslate X Plugin attempts to translate all content. The prevents Logic Hop Conditions from being properly saved. For full Logic Hop compatibility, update the qTranslate X settings with the following simple steps:

  1. Navigate to the qTranslate X Settings page from the Plugins page
  2. Click the Advanced tab
  3. Locate the Post Types sections
  4. Uncheck the checkboxes for
    • logichop-conditions
    • logichop-goals
  5. Click the Save Changes button

Themes

Currently there are no known Theme compatibility issues.

If you are experiencing compatibility issues with a third-party Theme, click here to contact us. Be sure to include the Theme name, version and details about the issue.